
Draw Commands
Command Description Menu Path

Arc Creates an Arc Draw

AreaBoundary Creates a PolyLine or Region entity from an enclosed area (dialog box variant) Draw

CenterLine Adds Centerline to selected entities Draw

Circle Creates a Circle Draw

Cloud Creates revision clouds to indicate that certain areas require or contain revisions (dialog box variant) Draw

EdgeMesh Creates a 3D PolygonMesh based on four adjoining edges Draw > Mesh

Ellipse Creates an Ellipse or an Elliptical Arc Draw

Face Creates a 3D face Draw > Mesh

FillArea Fills an area with a solid color or color gradient Draw

Hatch Fills a selected boundary with a pattern (dialog box variant) Draw

Helix Creates a 2D spiral or a 3D helix Draw

InfiniteLine Draws an infinite construction line Draw

InsertShape Inserts a shape from a shape file into the drawing Draw > Shape

Line Creates straight line segments Draw

LoadShape Loads shape files for use by the Shape command Draw > Shape

MakeBlock Creates a Block from selected entities (dialog box variant) Draw > Block

MakeBlockAttribute Creates a BlockAttribute definition (dialog box variant) Draw > Block

MarkDivisions Places evenly spaced point entities or Blocks along the length or perimeter of an entity Draw > Point

MarkLengths Places point entities or Blocks at measured intervals on an entity Draw > Point

Mask Covers existing entities with a blank area Draw

Mesh Creates a 3D PolygonMesh Draw > Mesh

Note Creates Text entities (dialog box variant) Draw > Text

Point Creates a point entity Draw

Polygon Creates an equilateral closed PolyLine Draw

PolyLine Creates 2D PolyLines Draw

PolyLine3D Creates a 3D PolyLine of straight line segments in 3D space Draw



Draw Commands
Command Description Menu Path

Ray Draws semi-infinite construction lines Draw

Rectangle Creates a rectangular PolyLine Draw

Region Converts an entity enclosing an area into a Region Draw

RevolvedMesh Creates a rotated surface about a specified axis Draw > Mesh

RichLine Creates multiple parallel lines Draw

Ring Creates a filled Circle or Ring Draw

RuledMesh Creates a ruled surface between two curves Draw > Mesh

SimpleNote Creates single line text Draw > Text

Sketch Creates freehand lines Draw

Solid Creates solid-filled 2D faces Draw > Mesh

Spline Creates quadratic or cubic Spline (NURBS) curves Draw

Table Creates a Table in the drawing (dialog box variant) Draw

TabulatedMesh Creates a tabulated surface from a path curve and a direction vector Draw > Mesh



Edit Commands
Command Description Menu Path

ClipboardCopy Copies entities to the clipboard Edit

Copy@ Copies entities with a specified reference point to the clipboard Edit

Cut Copies entities to the clipboard and deletes the entities Edit

Delete Removes entities from the drawing Edit

Find Finds and replaces Text in Notes, Annotations, and Dimension Text Edit

Paste Inserts data from the clipboard Edit

PasteAsBlock Inserts entities from the clipboard as Block Edit

PasteSelected Pastes entities from the OS clipboard by specifying a format Edit

Redo Reverses the effects of a previous U or UndoN command Edit

SelectAll Selects all drawing entities for subsequent modification commands Edit

U Reverses the most recent command Edit



Dimension Commands
Command Description Menu PathCommand Description Menu Path

AngleDimension Creates an angle Dimension Dimension

ArcLengthDimension Creates an Arc length Dimension Dimension

AutoDimension	 Creates dimensions automatically Dimension

ArrangeDimensions Arranges dimensions automatically Dimension

BaselineDimension Continues a linear, angular, or ordinate Dimension from the baseline of the previous or 
selected Dimension Dimension

CenterMark Creates a center mark or center lines of Circles and Arcs Dimension

ContinueDimension Continues a linear, angular, or ordinate Dimension from the second extension line of the 
previous or a selected Dimension Dimension

DiameterDimension Creates diameter Dimensions for Circles and Arcs Dimension

EditDimensionText Sets the justification of dimension text	 Dimension > Align Text

JoggedDimension Creates jogged radius Dimensions for Circles and Arcs Dimension

LinearDimension Creates a linear Dimension Dimension

OrdinateDimension Creates ordinate point Dimensions Dimension

OverrideDimensionStyle Overrides DimensionStyle variables Dimension

ParallelDimension Creates an aligned linear Dimension Dimension

RadiusDimension Creates radial Dimensions for Circles and Arcs Dimension

RebuildDimension Updates Dimensions with the active DimensionStyle Dimension

RelateDimension Reestablishes the relation of specified Dimensions to entities Dimension

ResetDimensionText Moves dimension text to its original position Dimension > Align Text

SmartDimension Creates Dimensions with a dimension type determined by the entity selected Dimension

SmartLeader Draws Leader lines and annotations Dimension

SplitDimension	 Splits and joins dimensions Dimension

Tolerance Creates Tolerances (datum indicators and basic dimension notation) Dimension



Command Description Menu Path

BatchPrint Prints multiple drawings to plotters, printers or files File

Check Evaluates the integrity of a drawing and can correct errors File

Clean Removes unused named References such as Blocks or Layers from the drawing  
(dialog box variant) File

Close Exits the drawing but not the program File

DrawingProperties Displays and edits the standard properties of the current drawing file and creates custom 
properties for the file File

eDrawings Starts the eDrawings® application to create, view, and share 3D models and 2D drawings File

Exit Exits the software File

Export Saves entities to other file formats File > Export

ExportDrawing Writes entities, Blocks, or the entire drawing to a new drawing file (dialog box variant) File > Export

ExportPDF Saves the current view of the graphics display to a PDF file (Portable Document Format) File > Export

ExportTable Exports table entity to .xlsx, .xls, .csv file File > Export

New Creates a new drawing file File

Open Opens an existing drawing file File

Preview Shows a preview for printing the drawing (dialog box variant). File

Print Plots the drawing to a plotter, printer, or file (dialog box variant) File

PrintConfiguration Defines Print Configurations to use as printing defaults for the Model and for Sheets File

Recover Repairs damaged drawings File

Save Saves the drawing under the current file name or a specified name File

SaveAs Saves an unnamed drawing with a file name or renames the current drawing File

Sheet Create, copy, rename, or delete Sheet tabs (layout mode to set up a printout) File

File Commands



Format Commands
Command Description Menu Path

ActivateLayer Activates the Layer of a specified entity Format > Layer Tools

Clean Removes unused named References such as Blocks or Layers from the drawing (dialog box 
variant) Format > File

DeleteLayer Deletes entities and the layer of selected entities Format > Layer Tools

DimensionStyle Creates and modifies DimensionStyles (dialog box variant) Format

DGNLayers Manages layers for a DGN underlay Format

DrawingBounds Defines the extent of the grid display and restrict the graphics area Format

EditScaleList Customizes the list of scales for printing, managing Print Configurations,  
and scaling Viewports in layout Sheets (dialog box variant) Format

FreezeLayer Freezes the Layers of selected entities Format > Layer Tools

HideLayer Turns off the Layer of the selected entity Format > Layer Tools

IsolateLayer Isolates the Layers of selected entities Format > Layer Tools

Layer Controls Layers and Layer properties (dialog box variant) Format

LayerPreview Previews the content of layers one by one for a set of specified layers Format > Layer Tools

LayerState Saves, restores, and manages configurations of Layer properties and states Format > Layer Tools

LineColor Sets the LineColor for new entities (dialog box variant) Format

LineStyle Creates, loads, and sets LineStyles (dialog box variant) Format

LineWeight Sets LineWeight options (dialog box variant) Format

LockLayer Locks the Layers of selected entities Format > Layer Tools

MatchLayer Changes the Layer of selected entities to match a destination Layer Format > Layer Tools

PDFLayers Manages layers for a PDF underlay Format

PointFormat Defines the type and size of point entities Format

PrintStyle Manages named PrintStyles (dialog box variant) Format

Rename Changes the names of named entities Format



Format Commands
Command Description Menu Path

RichLineStyle Creates and manages RichLineStyles Format

ShowLayers Turns on all Layers Format > Layer Tools

TableStyle Creates and manages TableStyles Format

TextStyle Creates or modifies TextStyles and sets the active TextStyle (dialog box variant) Format

ThawLayers Thaws all Layers Format > Layer Tools

ToActiveLayer Changes the Layers of specified entities to the active Layer Format > Layer Tools

UndoLayer Restores previous Layer settings Format > Layer Tools

UnisolateLayer Undoes Layer isolation Format > Layer Tools

UnitSystem Sets coordinate and angle display formats and precision (dialog box variant) Format

UnlockLayer Unlocks locked Layers Format > Layer Tools

DimensionStyle Creates and modifies DimensionStyles (dialog box variant) Format



Insert Commands
Command Description Menu Path

AttachDrawing Attaches a Referenced drawing to the current drawing Insert > Attach

AttachDGN Attaches a DGN to the current drawing Insert

AttachImage Attaches an image to the current drawing Insert > Attach

AttachPDF Attaches a PDF to the current drawing Insert

Field Creates Fields for annotations that are used to update information such as  
modification date, drawing name, and author Insert

Hyperlink Attaches a hyperlink to entities or modifies an existing hyperlink (dialog box variant) Insert

InsertBlock Inserts a Block or another drawing (dialog box variant) Insert

InsertObject Displays data from other programs in drawings  
(such as text documents, spreadsheets, or images) Insert

RebuildField Manually updates Fields in specified annotations Insert



Command Description Menu Path

Align3D Aligns entities with respect to other entities or other target points in 3D space Modify > 3D Operations

AnnEntityScale Adds and removes annotation scales for specified annotative entities  
(dialog box variant)

Modify > Annotation 
Scaling

AnnEntityScaleAdd Updates annotative entities to support the drawing’s active annotation scale Modify > Annotation 
Scaling

AnnEntityScaleRemove Updates annotative entities to remove the drawing’s active annotation scale from the 
entities’ annotation scales

Modify > Annotation 
Scaling

AnnReset Resets all scale representations of specified annotative entities to their  
original positions

Modify > Annotation 
Scaling

Chamfer Bevels the edges of drawing entities Modify

ChangeElements Adds or removes entities to Block definitions or References (so called Components) Modify > Component

ClipImage Defines a clipping boundary to hide portions of a referenced image

ClipReference Defines a clipping boundary to suppress display of portions of a Block or Reference Modify > Clip

ClipViewport Clips the display of Viewports on the active Sheet at irregular shapes Modify > Clip

CloseComponent Terminates in-place editing of a Block definition or a Reference Modify > Component

ConvertPolyLine Converts lightweight PolyLines to old-format, heavyweight PolyLines and vice versa Modify > Entity

Copy Duplicates entities Modify

Delete Removed entities from a drawing Modify

DiscardDuplicates Removed duplicated entities from a drawing Modify

EditAnnotation Edits items such as single-line Text, Dimension text, Leader annotation,  
and BlockAttribute definitions Modify > Entity

EditBasePoint Sets new insertion base points for Block definitions Modify > Component

EditBlockAttribute Modifies BlockAttributes (dialog box variant) Modify > Entity

EditBlockAttributeDefinition Modifies an existing BlockAttribute definition (dialog box variant)

EditComponent Edits in-place individual entities within Blocks or References Modify > Component

EditHatch Modifies an existing Hatch or Fill (dialog box variant) Modify > Entity

EditLength Lengthens or shortens an entity Modify

EditPolyLine Edits PolyLines, PolyLine vertices, and 3D PolygonMeshes Modify > Entity

Modify Commands



Modify Commands
Command Description Menu Path

EditBlockAttribute Modifies BlockAttributes (dialog box variant) Modify > Entity

EditBlockAttributeDefinition Modifies an existing BlockAttribute definition (dialog box variant)

EditComponent Edits in-place individual entities within Blocks or References Modify > Component

EditHatch Modifies an existing Hatch or Fill (dialog box variant) Modify > Entity

EditLength Lengthens or shortens an entity Modify

EditPolyLine Edits PolyLines, PolyLine vertices, and 3D PolygonMeshes Modify > Entity

EditRichLine Edits intersecting and adjoining RichLines, breaks and welds RichLines, and  
adds or deletes vertices to or from existing RichLines (dialog box variant) Modify > Entity

EditTable Changes text in a Table cell Modify > Entity

EditTableCell Inserts, deletes, merges, or resizes cells, rows, and columns in Tables Modify > Entity

EditTolerance Modifies Tolerances (datum indicators and basic dimension notation) Modify > Entity

Explode Breaks complex objects into their component entities Modify

Extend Extends entities to bounding edges defined by other entities Modify

HideEntities Hides selected entities Modify

IsolateEntities	 Isolates selected entities Modify

Fillet Rounds and fillets the edges of entities Modify

Mirror Creates a mirror image copy of entities Modify

Mirror3D Creates a mirror image of entities about a plane in 3D space Modify > 3D Operations

Move Displaces entities a specified distance in a specified direction Modify

Offset Offsets linear entities in parallel orientation Modify

Pattern Creates multiple copies of entities in a pattern (dialog box variant) Modify

Pattern3D Creates a linear or circular pattern of entities in 3D space Modify > 3D Operations

Properties Controls properties of existing entities Modify



Modify Commands
Command Description Menu Path

PropertyPainter Applies properties from one entity to selected entities Modify

PowerTrim Trims multiple, adjacent entities by dragging the pointer across each entity Modify

RemoveAttribute Removes the BlockAttribute name from a Block, but keeps the  
BlockAttribute value as text Modify

Rotate Rotates entities about a base point Modify

Rotate3D Moves entities about a 3D axis Modify > 3D Operations

SaveComponent Saves modifications done during in-place editing of Block defintions or  
References and exits Component editing mode Modify > Component

Scale Enlarges or reduces specified entities equally in the X, Y, and Z directions Modify

SelectMatching	 Selects all entities matching the properties of the selected entity Modify

Split Deletes parts of entities or splits entities in two Modify

Stretch Moves or stretches entities Modify

Trim Trims entities at a cutting edge defined by other entities Modify

QuickModify Copies, moves, rotates, and scales entities in one operation Modify

UnisolateEntities Unisolates isolated entities Modify

Weld Joins two entities into a single entity Modify



Tools Commands
Command Description Menu Path

Addins	 Opens the DraftSight add-ins tool

CCS Sets, saves, and restores custom coordinate systems (CCS) Tools > New CCS

CSStyle Manages custom coordinate systems (CCS) Tools

Customize Customizes user interface elements such as menus, toolbars, and workspaces Tools

DisplayOrder Changes the display order of drawing entities and inserted images in the drawings Tools

DrawCompare Opens the drawing comparison tool Tools

DesignResources Shows or hides the design resources palette Tools

DraftingOptions Sets drafting options like Snap, Grid, Ortho mode, Polar Guides, EntitySnaps (ESnaps), 
and EntityTracking (ETrack) Tools

DrawingStandards Associates drawing standards to the current drawing, determines the drawing catego-
ries to check, and sets notification and audit options Tools > Standards

EditEntityGroup Adds and removes entities to or from EntityGroups, or renames EntityGroups Tools > Entity Groups

Gesture Customizes mouse gestures Tools

GetAngle Measures angles between two line or polyline segments

GetArea Calculates the area and perimeter of entities or of defined areas Tools > Inquiry

GetDistance Measures the distance and angle between two points Tools > Inquiry

GetMassProperties Calculates and displays the mass properties of 3D solids and regions  
(Inquiry sub menu)

GetProperties Displays information about selected entities Tools > Inquiry

GetXY Displays the coordinate values of a location Tools > Inquiry



Tools Commands
Command Description Menu Path

LoadApplication Loads applications for use in the program Tools

LoadScript Executes a sequence of commands from a script Tools

OpenReference Opens a Referenced drawing in a new drawing window Tools

Options Configures program operating parameters Tools

QuickGroup Quickly creates EntityGroups Tools > Enitity Groups

QuickUngroup Quickly ungroups EntityGroups Tools > Enitity Groups

References Displays the References palette Tools

RecordMacro Starts the record macro tool Tools > Macro

StopMacro Stops the record macro tool Tools > Macro

VerifyStandards Verifies that the drawing conforms to industry, corporate, and custom standards Tools > Standards



View Commands
Command Description Menu Path

Arender Displays the rendered drawing in a separate window View

CommandHistory Opens the separate command history window View > Display

CSIcon Sets the visibility and position of the coordinate symbol (CS icon) View > Display > CCS Icon

DisplayBlockAttributes Defines visibility of BlockAttributes View > Display

FullScreen Displays the graphics area as a full screen (without toolbars and palettes) View

HideView Creates a hidden line view View

Pan Moves the drawing display in the active ViewTile (dynamic pan) View > Pan

PanDown Pans down View > Pan

PanLeft Pans left View > Pan

PanRight Pans right View > Pan

PanUp Pans up View > Pan

Rebuild Rebuilds the drawing and refreshes the active ViewTile View

RebuildAll Rebuilds the drawing and refreshes all ViewTiles View

RefreshAll Refreshes the display of all currently open ViewTiles View

RollView Rotates the view in 3D space View > 3D Orbit

RollViewCenter Sets the center of rotation for constraint orbit view and starts rotation View > 3D Orbit

RollViewContinuous Rotates the view in 3D space with continuous motion about a specified pivot point View > 3D Orbit

RollViewFree Rotates the view in 3D space without constraining roll View > 3D Orbit

RollViewHorizontal Swivels the view in 3D space horizontally (left and right) about an  
imaginary vertical axis View > 3D Orbit

RollViewVertical Tilts the view in 3D space vertically (up and down) about an imaginary horizontal axis View > 3D Orbit

ShadeView Determines the ShadeView mode View
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Our 3DEXPERIENCE® platform powers our brand applications, serving 11 industries, and provides a rich portfolio of industry 
solution experiences. 
Dassault Systèmes, the 3DEXPERIENCE Company, is a catalyst for human progress. We provide business and people with collaborative virtual environments to imagine sustainable innovations. By creating 
‘virtual experience twins’ of the real world with our 3DEXPERIENCE platform and applications, our customers push the boundaries of innovation, learning and production. 

Dassault Systèmes’ 20,000 employees are bringing value to more than 270,000 customers of all sizes, in all industries, in more than 140 countries. For more information, visit www.3ds.com.

Europe/Middle East/Africa
Dassault Systèmes
10, rue Marcel Dassault
CS 40501
78946 Vélizy-Villacoublay Cedex
France

Americas
Dassault Systèmes
175 Wyman Street
Waltham, Massachusetts
02451-1223
USA

Asia-Pacific
Dassault Systèmes K.K.
ThinkPark Tower
2-1-1 Osaki, Shinagawa-ku,
Tokyo 141-6020
Japan

View Commands
Command Description Menu Path

Views Saves, restores and manages user-defined model and Sheet views,  
and preset views (dialog box variant) View

ViewTiles Creates and controls single or multiple Model ViewTiles or Sheet Viewports  
(dialog box variant) View > View Tiles

Zoom Increases or decreases the visible part of the drawing View

ZoomBack Zooms to previous view View > Zoom

ZoomDynamic Zooms the drawing at realtime (dynamic zoom) View > Zoom

ZoomFactor Zooms by a factor View > Zoom

ZoomFit Zooms to the drawing extents View > Zoom

ZoomIn Zooms in to the drawing View > Zoom

ZoomOut Zooms out from the drawing View > Zoom

ZoomWindow Zooms to a region of the drawing specified by a box View > Zoom


